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Bearing Behavior of a Piled Raft
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Pile Modeling in GTS NX
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Solid Element Model
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Solid Element Model
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Beam-Solid Connectivity Model
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Beam-Solid Connectivity Model
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Line-to-Solid Interface Model
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Line-to-Solid Interface Model



GTS NX

10

Point-to-Solid Interface Model
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Line-to-Solid Interface Elements

Pile bearing capacity is an input and not a result of FEM calculation.
→ To check global pile response from soil modelling and pile-soil interaction
(Displacements, bending moments, axial forces, shaft friction, tip force, etc.)
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Pile Element Parameters
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Pile Element Parameters
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Because the pile size, length, neighboring ground material properties all affect the pile element parameters, it is
ideal to use the results of a loading test.

However, if there are no test results, the Ultimate Shaft Resistance, Lateral Subgrade Reaction Modulus and End
Bearing Capacity of a pile can be calculated using the formulas proposed by the design code and the neighboring
ground parameters (unit weight, cohesion, friction angle etc.).

1. Using loading test results
For example, if a load of 1000kN was found before failure from the pile loading test and the pile length was 10m,
the Ultimate shear force is [1000kN/10m/1m] = 100kN/m2. Here, the 1m is the unit length of the input pile element
thickness. The Shear stiffness modulus is the slope of the linear section on the relationship graph with relative
displacement until the 1000kN load is applied. If we assume that the relative displacement at 1000kN is 0.01m, the
Shear stiffness modulus becomes [100kN/m2 / 0.01m] = 10000kN/m3.

2. Using the Ultimate Shaft Resistance results
For each design code, various formulas are suggested to predict the Ultimate bearing capacity of a pile according
to ground and pile section properties. For example, if the calculated Ultimate shaft resistance is 50kN/m2 and the
Shaft surface area of the pile(equivalent circumference) is 3m, input 50kN/m2 for the Ultimate shear force and 3m
for the Pile element thickness respectively, or input 150kN/m2 for the Ultimate shear force and the unit length of the
Pile element thickness 1m. The Pile element length is automatically taken into account.

Because the load-relative displacement has no relationship, if the allowable settlement is assumed to occur at the
Ultimate bearing capacity, the Shear stiffness modulus applied to the analysis can be inferred with reference to the
allowable settlement. If the allowable settlement is 0.025m for the example above, the Shear stiffness modulus is
[150kN/m2 / 0.025m] = 6000kN/m3. If the Pile element thickness is 3m, entering [50kN/m2 / 0.025m] = 2000kN/m3

still gives the same results. However, if a different numerical value from the unit length is input for the Pile element
thickness, be aware that the same Normal stiffness modulus is equally applied.

Pile Element Parameters
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Pile Modelling in GTS NX

Type Axial behaviour Lateral behaviour
(Pile head loading)

Lateral behaviour
(Horizontal soil displacement)

Modelling approach Pile group Single pile Pile group Single pile Pile group Single pile

Solid elements A A A A A A

Pile elements A A C C B B

A : The best modelling choice for the correspondent application

B : Reasonable modelling

C : First order approximation

Limitations of pile elements
1. Pile elements have capabilities for lateral loading behaviour in case of rough pile-soil contact

(full bonding) and small soil displacements.
2. When using ‘standard’ mesh around pile elements (no local refinement), stiffness and lateral

capacity are over-estimated.
3. The pile diameter determines the size of the elastic zone in the soil around the pile in which

plastic soil behaviour is excluded. By considering this in the modelling, it makes the pile
elements behave almost like a solid elements.
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Verification
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Verification
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00 Overview

• This tutorial demonstrates some of 
the support systems by modelling a 
piled raft foundation.

• It is possible to review in detail the 
stress distributions on cross-sections, 
which is not possible in 2D models.

• The evaluation of the soil-structure 
behavior is done by using pile 
elements, not by simple beam 
elements.

• Also, pile elements are perfect for 
evaluating the soil-structure behavior 
because it can consider the influence 
of interface between pile and adjacent 
ground.

Procedure
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01 Material & Property

Name Clay

Material Isotropic

Model Type Mohr-Coulomb

General

Elastic Modulus(E) [kN/m2] 5,000

Poisson’s Ratio(v) 0.35

Unit Weight(γ) [kN/m3] 18

Unit Weight(γsat) [kN/m3] 21

Ko Auto

Non-Linear

Cohesion(c) [kN/m2] 4

Frictional Angle(Φ) [deg] 30

Dilatancy Angle(Φ) [deg] 0

Tensile Strength [kN/m2] 0

[unit : kN, m]Soil
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01 Material & Property

Name Raft Pile

Material Isotropic Isotropic

Model Type Elastic Elastic

Elastic Modulus (E) [kN/m2] 3.5e+07 3.5e+07

Poisson’s Ratio (v) 0.2 0.2

Unit Weight (γ) [kN/m3] 25 25

Element Type Shell Beam

Thickness [m] 0.5 -

Diameter [m] - 0.3

Name Pile Interface

Model Type Pile

Ultimate Shear Force [kN/m2] 100

Shear Stiffness Modulus (Kt) [kN/m3] 5e+03

Normal Stiffness Modulus (Kn) [kN/m3] 5e+04

Tip Bearing Capacity [kN] 100

Tip Spring Stiffness [kN/m] 5e+04

[unit : kN, m]

[unit : kN, m]

Structure

Pile



GTS NX

21

02 Geometry Modelling

1

Procedure
1

Start the tutorial by opening the 
start file in which basic materials 
and properties have already been 
predefined.

File > Open
- Select ‘1. 3D Piled Raft 
Foundation_start.gts’
- Open
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In GTS NX, 2 types of coordinate system are used: Global coordinate system (GCS) and Work plane coordinate system

(WCS). GCS is a fixed coordinate system indicated in red(X-axis), green(Y-axis), and blue (Z-axis) colors at the right

bottom corner on the screen. WCS is a coordinate system which locates at center of the working window and moves with the

work plane. So if the work plane changes, WCS will also change. 3D absolute coordinates are necessary to locate geometry

in the space, but practically relative coordinates are commonly used, for example to indicate length. You can process

modeling by inputting 2D coordinates (XY plane in WCS) after moving the work plane to proper location.

Keep in mind that in case of inputting direction for extruding geometry or defining load/boundary conditions, it always follows

Global coordinate system.

02 Geometry Modelling
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1

Create a rectangle for raft and 
points for pile head.

Geometry > Point & Curve > 
Rectangle
- Double click ‘Work-Tree > 
Work Plane > XY(0,0,1)’
- Location: (-6,-6) <12,12>
- OK

Geometry > Point & Curve > 
Point
- Tabular Input tab
- Read From File…
- ‘Location of Piles.txt’
- OK

( ): ‘ABS x, y’
< >: ‘REL dx, dy’

2



2

02 Geometry Modelling

Procedure



1
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1

Create lines for pile and ground 
solid.

Geometry > Protrude > Extrude
- Extrude tab
- Selection filter: Point (V)
- Select: 9 points (pile head)
- Direction: Z-axis
- Reverse Direction: Check on
- Length: 15
- Geometry Set: Pile 
- OK

Geometry > Surface & Solid > 
Box
- Origin Point: -60,-60,-30
- Width X: 120
- Width Y: 120
- Height: 30
- Geometry Set: Ground 
- OK

2

02 Geometry Modelling

Procedure

1

2
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1

Project pile location and the raft 
area on the top surface of solid.

Geometry > Surface & Solid > 
Imprint
- Point tab
- Select Target: Top Surface
- Select Tool: 9 points for piles
- Select: Direction of Shortest 
Path Line
- Apply

- Curve tab
- Select Target: Top Surface
- Select Tool: 4 edges for raft
- Select: Direction of Shortest 
Path Line
- OK

02 Geometry Modelling

Procedure

1

2
2
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1

Specify size of elements for the 
raft foundation and generate 
ground mesh.

Mesh > Control > Size Ctrl.
- Edge tab
- View Toolbar: Top
- Select: 4 edges for the raft 
foundation
- Method: Interval Length
- Mesh Size: 1
- OK

Mesh > Generate > 3D
- Auto-Solid tab
- Select: Ground (Solid)
- Size: 10
- Property: 1: Clay
- Mesh Set: Ground
- OK

2

2

03 Mesh Generation

Procedure

1
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1

Generate mesh for the raft 
foundation and piles.

- Show only the geometry solid 
for Ground
- Select it and right click to select 
‘Display Mode > Line Only’
Mesh > Element > Extract
- Geometry tab
- Type: Face
- Select: 1 surface for the raft 
foundation
- Property: 2: Raft
- Mesh Set: Raft
- OK

Mesh > Generate > 1D
- Show geometry lines for pile
- Select: all lines
- Division: 1
- Property: 3: Pile
- Mesh Set: Pile
- OK

2

2

03 Mesh Generation

Procedure

1
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1

Generate mesh for the pile 
interface and pile tip.

Mesh > Element > Pile/Pile Tip
- Pile tab
- Select: all Pile elements
- Property: 4: Pile Interface
- Mesh Set: Pile Interface
- Apply

- Pile Tip tab
- View Toolbar: Front
- Select: all bottom nodes of 
Pile elements (as shown in the 
figure)
- Property: 5: Pile Tip
- Mesh Set: Pile Tip
- OK

03 Mesh Generation

Procedure

2

2

1
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The behavior of pile elements can be divided into a normal behavior and a tangential behavior. First, the normal behavior
between the pile and the surrounding ground is considered as fixed and rigid, whereas the tangential behavior is a nonlinear
elastic behavior. The nonlinear elastic behavior is divided into the yield force and the yield function assigned.

The graph bellow represents the relative displacement between the 2 bodies and the friction when yield force is defined. If the
relation is defined by a function, the relation between relative displacement and friction can be defined more precisely.

The Pile tip element works as solid-point interface that presents the relative behavior between the ground elements and pile
node. In the element coordinate system of the pile tip element regard the normal direction behavior toward the element as
rigid behavior just like a pile behavior. And, regard the tangent direction behavior as nonlinear elastic behavior.

To define the behavior, the material and property of a pile element can be entered based on test data, such as Load Test.

For more information about entering parameters of pile element, look up [User Manual] Ch4 (General Material) or Select F1
for [Online Manual].

03 Mesh Generation
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1

Merge nodes between raft and 
pile head.

Mesh > Node > Merge
- Merge tab
- Select: all nodes for raft and 
piles
- Click: Find
- OK

03 Mesh Generation

Procedure

1
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Pile connection

In the case of the pile connection point coinciding with pile cap elements, the connection behaviour
is as follows:

1. Free (Mesh > Element > Pile)

The connection point is free to move and rotate relative to the
surrounding soil and the pile cap element. The pile interacts with the
surrounding soil and the pile cap elements only through the pile
interface elements. Note that the pile cap elements are not free to
move and rotate relative to the surrounding soil.

2. Rigid (Mesh > Node > Merge)

The displacement and rotation at the pile connection point are both
coupled with the displacement and rotation of the pile cap and/or soil
element in which the pile top is located.

3. Hinged (Mesh > Element > Parameters > Beam End Release)

The displacement at the connection point of the pile is directly coupled
with the displacement of the pile cap element and/or the surrounding
soil in which the pile connection point is located, which means that
they undergo exactly the same displacement.
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1

Assign boundary conditions to the 
external boundary of the model 
and piles.

Static/Slope Analysis >
Boundary > Constraint
- Show all mesh sets
- Auto tab
- Boundary Set: Ground support
- Apply

- Advanced tab
- Show only ‘Pile’ mesh set
- Object Type: Node
- Select: all nodes of Pile 
elements
- DOF: Rz
- Boundary Set: Pile
- OK

04 Load & Boundary Conditions

Procedure

2

2

1



Axial rotation constraints to
prevent the degree of freedom
errors for torsion of beam
elements


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1

Create self weight and a surface 
load of the raft foundation.

Static/Slope Analysis > Load > 
Self Weight
- Show all mesh sets
- Gz: -1
- Load Set: Self weight
- OK

Static/Slope Analysis > Load > 
Pressure
- Show only ‘Raft’ mesh set
- Face tab
- Object Type: 2D Element
- Select: all elements of Raft
- Direction Type: Normal
- P or P1: 30 kN/m2

- Load Set: Surface load
- OK

04 Load & Boundary Conditions

Procedure

2

2

1
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1

Define a construction stage of the 
piled raft foundation.

Static/Slope Analysis > 
Construction Stage > Stage Set
- Stage Type: Stress
- Add
- Double click the ‘Construction 
Stage Set-1’

- Stage Name: Initial phase
- Select mesh, boundary and load 
sets, and drag & drop them into 
Activated Data from Set Data. (as 
shown in the figure)
- Show Data: Activate
- Define Water Level for Global: 
Check on ‘-3m’
- Clear Displacement: Check on
- Save

05 Define Construction Stages

Procedure

1

2 2
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1

- New
- Stage Name: Piled raft
- Select mesh and boundary sets, 
and drag & drop them into 
Activated Data from Set Data. (as 
shown in the figure)
- Clear Displacement: Check on
- Save

05
Procedure

1

Define Construction Stages
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1

- New
- Stage Name: Surface load
- Select load set, and drag & drop 
them into Activated Data from Set 
Data. (as shown in the figure)
- Save

05
Procedure

1

Define Construction Stages
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1

Analysis > Analysis Case > 
General
- Title: Piled raft foundation
- Solution Type: Construction 
Stage
- Analysis Control
- Initial Stage for Stress Analysis: 
Check on
- Initial Stage: 1:Initial phase
- Apply K0 Condition: Check on
- OK
- Output Control
- Strain: Check on
- OK
- OK

Analysis > Analysis > Perform
- Analysis Case: Check on
- OK

06 Analysis Setting

Procedure
1

2 2
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1

Surface load > Displacement >  
TOTAL TRANSLATION (V)

Result > General > Smooth: 
Fringe
Result > General > Deform: 
Undeformed
- Properties: Deform
Result > Show/Hide > Actual 
Deformation

Result > Advanced > Probe
- Max
- Min

07 Results

Procedure
1

2 2
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1

Advanced View Control: Clipping 
Plane
- Define Plane
- X: 0 m
- Add
- Y: 0 m (Reverse)
- Add
- Close
- Always Show edges: Check off
- Plane Composite: Union
- Close

Surface load > Beam Element 
Forces > AXIAL FORCE
(The axial force, as expected, 
decreases with depth into the 
pile.)

Result > General > No Results: 
Exclude

07 Results

Procedure
1

22



GTS NX

40

1

Surface load > Pile Force > 
TANGENTIAL X

Surface load > Shell Element 
Forces > BENDING MOMENT 
YY

07 Results

Procedure
1

22

Shaft friction force between pile
and ground






